Suche auf jeder Seite einbinden

Sooks82Sooks82 Forum Newbie
bearbeitet April 2011 in TYPO3 Extensions
Hey,

ich weiß, dass es dazu jede Menge Hilfe über google finde. Aber leider hab ichs dennoch nicht geschafft: Ich möchte ein Suchfeld auf jeder Seite einbinden.

Der Suchteil im Template:
[HTML]
<div id="search">
###SUCHE###
</div>[/HTML]Ist zwar ein Marker drin, habs aber auch gemappt, da ich beides versucht hab. Der Objektpfad des Mappings ist lib.suche.
Mein TS bis jetzt:
[typoscript]#Suche
lib.suche < plugin.tx_indexedsearch_pi1[/typoscript]Was muss da jetzt genau ins TypoScript (Die ID der Such-Seite ist 64)
Ob mit Marker oder Mapping ist egal :smile: Wäre echt ne große Hilfe, hänge jetzt schon sehr lange daran fest.

Kommentare

  • xXRodneyXxxXRodneyXx Forum Zuschauer
    bearbeitet April 2011
    Hi,

    schau dir mal die macina_searchbox an. Das sollte dir weiterhelfen.
  • Sooks82Sooks82 Forum Newbie
    bearbeitet April 2011
    Die Extension habe ich, eingebunden kriege ich sie trotzdem nicht :-/
  • xXRodneyXxxXRodneyXx Forum Zuschauer
    bearbeitet April 2011
    Kannst du mal bitte den code dazu schreiben? Dann kann ich mal einen Blick drauf werfen.
  • Sooks82Sooks82 Forum Newbie
    bearbeitet April 2011
    [typoscript]#######Search #########
    lib.suche < plugin.tx_macinasearchbox_pi1
    lib.suche {
    templateFile = fileadmin/templates/template_search.htm
    pidSearchpage = 64
    }

    #plugin.tx_indexedsearch.templateFile = fileadmin/templates/template_search_result.htm


    plugin.tx_indexedsearch {
    show {
    rules=0
    parsetimes=0
    L2sections=1
    L1sections=1
    LxALLtypes=0
    clearSearchBox = 0
    clearSearchBox.enableSubSearchCheckBox=0
    }

    # Blinding of option-selectors / values in these (advanced search) (see $optValues array in source code for options + extResume checkbox)
    blind {
    type=0
    defOp=0
    sections=1
    media=0
    order=0
    group=0
    lang=0
    desc=0
    results=0

    # defOp.1=1
    # extResume=1
    }
    rules_stdWrap {
    }
    sectionlinks_stdWrap {
    }
    path_stdWrap {
    }
    # search {
    # rootPidList = -1
    # page_links =
    # }

    result_link_target =

    tableParams {
    secHead = border="0" cellpadding="0" cellspacing="0" width="100%"
    searchBox = border="0" cellpadding="0" cellspacing="0"
    searchRes = border="0" cellpadding="0" cellspacing="0" width="100%"
    }
    forwardSearchWordsInResultLink = 0

    # Setting default values for piVars (please see the source code for the form-field names which you can preset values for here)
    _DEFAULT_PI_VARS.extResume=1
    _CSS_DEFAULT_STYLE >
    _LOCAL_LANG {
    }
    }[/typoscript]
    Das ist alles von einer alten Seite geklaut (die ich zur Zeit am neu machen bin). Damit habs ichs jetzt endlich eingebaut gekriegt. D.h. ich weiß jetzt nicht wirklich, was er da alles tut =D
    Also mir wird jetzt zwar ein Suchfeld angezeigt, habs auch mit CSS entsprechend angepasst, allerdings kriege ich auf der entsprechenden Seite keine Ergebnisse. Eine Idee worans liegen könnte?
  • xXRodneyXxxXRodneyXx Forum Zuschauer
    bearbeitet April 2011
    Das es jetzt läuft ist ja schonmal ein Anfang :wink:

    Ist die Seite mit der ID 64 deine Suchseite? Hast du dort indexed_search eingebunden? Dann könnte es noch daran liegen das der cache ausgestellt ist, ohne den es nicht geht. Sind schon Seiten im Index?
  • Sooks82Sooks82 Forum Newbie
    bearbeitet April 2011
    Ist Seite mit der ID 64 deine Suchseite? - ja
    Hast du dort indexed_search eingebunden? -ja, funktioniert auch, solagne ich die von dieser Seite aus benutze
    Dann könnte es noch daran liegen das der cache ausgestellt ist, ohne den es nicht geht. - der normale Typo3 cache müsste an sein, habe nichts dran verändert.
    Sind schon Seiten im Index? -sofern man das manuell tun muss nicht, allerdings dürfte er dann auch nichts über die suche-seite selbst finden oder?

    edit: er zeigt übrigens auch nicht die Meldung "Sorry, your search was empty!" an, die er normalerweise anzeigt, wenn er nichts finden.
  • Sooks82Sooks82 Forum Newbie
    bearbeitet April 2011
    Kann keiner helfen? Kriegs einfach nicht raus :/
Anmelden oder Registrieren, um zu kommentieren.